ESP32-box not starting, only flashing red

Currently my box isn’t starting normally anymore. Just flashing red, even though J100 isn’t shorted.

Here’s what I did yesterday:

  • After connecting the ESP32-box to UART and shorting the jumper I was able to connect to it to my computer. Serial monitor showed the right output (Download mode) and after setting up the teddycloud server I was able to download the firmware via the “Read ESP32”-button.
  • Connection was a bit shaky, first approaches did not finish, but the final ones were complete. In addition to downloading it via webserial I was also able to download it using esptool on my Windows machine.
  • I tried to get the certs from the image, but did not succeed (it said /assets is missing).
  • Wanted to call it a night and solve that issue sometime else. But when I then rebuilt the box to it’s original working state I couldn’t get it running in the normal way anymore: When I disconnect the jumper and put it onto the power station it only flashes red every now and then.

Today I did a bit of troubleshooting, trying to reset my changes:

  • When I listen with serial monitor I get SPI_FAST_FLASH_BOOT, so that looks okay. But the rest of the box isn’t as it should be.
  • I just removed the bit of soldering I did (yesterday I added a contact for the J100 jumper and 3 cables for UART) and cleaned everything up in case that caused issues. But it’s still not working, just flashing red.

Is there anything I could do or test to get the box running again? Did I do anything I shouldn’t have (thought until know I’m just reading stuff, haven’t patched anything yet)?

Exact message without the J100 jumper is

ESP-ROM:esp32s3-20210327
Build:Mar 27 2021
rst:0x7 (TG0WDT_SYS_RST),boot:0x8 (SPI_FAST_FLASH_BOOT)
Saved PC:0x40049b21
invalid header: 0xffffffff

The invalid header stuff is coming endlessly, every now and then disrupted by the above output.

With jumper connected:

ESP-ROM:esp32s3-20210327
Build:Mar 27 2021
rst:0x1 (POWERON),boot:0x0 (DOWNLOAD(USB/UART0))
waiting for download

No invalid header, just the above message, once.

It’s probably the TG0WDT_SYS_RST that shows the issue, isn’t it? Just saw that it seems to be an ESP32 thing, but found no resolution i could apply to the toniebox.

Copied from Telegram

@g3gg0 wanted a mention :slight_smile:

Analyzed the different images I read via teddycloud and esptool and found they have the same md5, so I guess it’s at least not total gibberish.

Loading the file with binwalk won’t help much:

# binwalk -v ESP32_f412fa902b04.bin

Scan Time:     2024-01-22 22:19:40
Target File:   /teddycloud/data/firmware/ESP32_f412fa902b04.bin
MD5 Checksum:  316cad424069d1cae53626baf766affa
Signatures:    411

DECIMAL       HEXADECIMAL     DESCRIPTION
--------------------------------------------------------------------------------

What is the expected output and are there any parameters I might have missed?

can you send me the file via pm?

you can use https://upload.g3gg0.de/ to upload files, then send me the D/L link

File received.

I have unstatisfying news for you. For whatever reason the whole file is filled with 0xFF.

  • can you double-check if there is for sure no short between pins of the flash or a bad solder joint?
  • are you sure you didn’t use any SOIC-clamp or alike, but only used Rx/Tx pins?
  • you have in your teddycloud installation no other backup file than this FFed one?

Hey, haven’t been online yesterday. Already wrote you a message via Telegram, but to let anybody else know (after all I don’t wanna be DenverCoder9):

The box was brand-new but seemed fishy from the beginning. Before opening it, it already crashed twice during initial set up. Also it was only working when battery was disconnected. So before doing anything more intrusive with it I decided to sent it back.

Sorry for not getting much more into it, hope someone reading this in the future with similar issues can take over from here on.