Teddycloud ESP Setup issue, confirmation that patched toniebox is working

i got a new tonie box.
connected it to wifi via this site:
Connect the box without the setup assistant.
Box said it is happy and ready to work

i tried to follow the github instructions for ESP32.
i used an pi4 to host the docker container and run the uart commands.
the webserial did not work for me unfortunatelly. i got a hint on the forum how to disable the httponly option. :slight_smile:
in the beginning i used the mini uart and got random issues. Stuck at different percentages from the progress bar.
I also saw issues with the esptool while using the mini uart. like read errors at different places.
So i switched to the PL01 uart on the pi and the esptool was now working but the webserial still did not finish. i only used the pi4 due to 3.3V on the RX/TX, my other usb dongle has only 5V.
Got stuck at a 100% and then i saw a timeout.
I tried it with default docker compose file and change the volumnes to map those to the host.
So i can transfer them later to unraid. Where teddycloud should run at the end.
But changing the voloumnes did not change the outcome of the webserial. (i though some permission thingies.)

โ†’ in Legacy mode i was able to read the chip.
Did it three times, always had to powercycle the board.
Checksum of the files was matching. :+1:

So i extraced the certificates of the bin file
the first time i overlooked the server source :frowning:

cp certs/server/ca.der certs/client/esp32-fakeca/CA.DER

but the second time i got it.

then i patched the file via legacy mode again due to not cooperating webinterface.
i put in the ip address of my teddycloud docker container from unraid.
which ip address is for whatever reason not showing up in my fritz box.
i gave the docker container a separte ip address so i can use port 443 and 80.
during the flashing of the ESP i did not notice any error that might explain this situtation.

i see some values on the statistics, but i do not get any output on my tonie.

So far i only have one creative tony, that i cannot find in the teddycloud despite my tonie box.

Could you let me know what is going on?
What am i missing :sob:

here a some screenshots i am refering too

My tonie box shows a constant green light when i connect the battery.
and when i toggle on the cloud feature the red Boxine box on the top right corner turns green.
So i assume i got the right CA.

Can i still use the tonie app with the patched firmware?

What is exactly the problem you have?

Is the box isnโ€™t working any more? Is it just not connecting to teddyCloud?

my โ€œproblemโ€ is that i do not see the tonie box connecting to the teddy cloud.
the log from the docker looks clean in my opinion.

however i did not use the tonie box before. so i do not know how the toniebox should react.

I would have assume when i put the creative tony on the toniebox after i flashed the patched firmware.
that i would see some log in the teddy cloud.

and so i do not see that :frowning:

So i assume i screwed up the flashing process, somewhere.
Or the teddycloud docker on unraid is not setup correct.

Please first of all follow this troubleshooting guide.

ok, problem solved.
i started from scratch and now i see my box in teddy cloud.
thx for your efforts !!!11!

1 Like