TeddyCloud <--> SD-Card media transfer not working

Hi everybody,
thank you for this wonderful project! Unfortunately, I experience issues with the web-interface of TeddyCloud. Only media (TAF) files are not transferred from TeddyCloud to Toniebox or vice-versa. I can upload files manually to SD-card via TeddyBench, though.

Strangely, the directory structure is synchronized and metadata is displayed. Each directory containing the JSON-file and nothing else. I can’t find anything suspicious on the log.


My background: I’m new to the whole Tonies-world, but finally acquired my first CC3200 box, connected via UART, made a backup and replaced the bootloader and CA-certificate and setup TeddyCloud as described in the various ressources on Github, the website and this forum. This is all new to me, but it appears to have succeeded in the end. Playback of original Tonies is working as well as using a custom tag with custom content, which I’ve created using TeddyBench and manually placed on the SD-card.

Any help is greatly appreciated – thank you in advance!

Hi ya,

From my experience using teddycloud…

first, You have to enable cache in the administration gui of teddycloud. And even then only newly added tonies get the taf file automatically in teddycloud currently. There is no transfer of taf files from toniebox to teddycloud.

What you could do… remove the original tonies folders from the sd card and then place the tonies again on the box. This will cause a new download of the taf file and then it will also be stored in the teddycloud.

Another way is, that you transfer the content of the sd card (the uuid folders and their content) manually to the teddycloud to data/content/default.

If the taf file on teddycloud, the direction teddycloud —> toniebox should work fine (custom ones must be marked in the json with nocloud = true)

1 Like

teddyCloud cannot download content from the box.

You are not describing what you tried with teddyCloud to provide content for your boxes.
What you tried?

1 Like

Thank you all for your quick responses, I am really grateful!

Thank you very much for this clarification! Indeed this works all as expected and I didn’t understand the functionality of TeddyCloud properly. I can verify exactly the described behaviour, so everything works as intended :slight_smile:

Maybe the following part is helpful for someone facing similar issues as me.

I tried uploading and encoding via the web-interface of TeddyCloud, but got no response from TeddyCloud itself (http connection). After some trial and error I found out, that file upload and encoding does work, but only when connected via https to TeddyCloud. I don’t quite understand that, but I’m by no means an expert. Any further explanation is very welcome!

Thank you all for taking the time and effort helping me out! :pray: