Getting Certs from ESP32

Hi,

i found my way to this Forum because of the great CCC Talk. I had to order a box for … erm … my son.
Im Interested in setting up teddyCloud. Iam more of a Software guy, so im pretty new to dumping flashs from ESPs. And thats where most of my questions are.

I didnt open the box yet. I have just connected it to the Internet and made the tonies Setup so it can update its Firmware.

I have found this page where the Dumping of the certificates is mentioned:

ESP32 | Toniebox Hacking (revvox.de)

I think the mentioned esptool ist this one from espressif? Releases · espressif/esptool · GitHub

Then there is the mention of jumper J100. Is there a picture of where to find it? And how do i reset the box? Is the board in this state still connected to the battery pack and running “normally”?

After that there is a mention of serial monitor. What is that and how do i check things with it? :smiley:

Can someone tell me which commands to run in esptool, when succesfully connected to the board with the UART?

And my last question. Is there any UART recommended to do all this or any Hardware needed other than just the UART?

This got much longer than expected. I hope i did not miss anything in the documentation. Thanks in advance.

Maybe these questions also need to be answered in the Ultimate Noob Guide , because thats where i see me in the Hardware Category:D

:raised_hands:

Please first check, what kind of box you have. It may be a v1-v4.
Then you can follow the wiki for your type of box

On this ESP32 board, I already soldered sockets onto the important places. J100 is one of the soldered jumper double pins.

Just cut the power and reconnect battery, powersupply or both. If J100 is shorted, the box won’t boot and the LED will stay off.

You don’t necessarily need to use the esptool. You may use the teddyCloud interface for that.

You only need a 3.3V USB-UART for the CC3200/ESP32 boxes and some (jumper) wires, maybe a clamp. Really depends if you want to solder something onto your box or not. For the CC32XX it is a bit different…

I checked the Mac Adress. The vendor is Espressif, so i guess its the ESP or did they also produce the CCs? If so, then i would open it to check.

The rest seems doable then i think. Thank you for your quick response. Its time to order an UART then :slight_smile:

I will post again when i fail or when successfull :smiley:

Yes, it is a ESP32 box then.

1 Like

I will try my best, since I don’t have an ESP-box myself (yet). Maybe my sister has one :smiley: but it will take some time

My Uart to USB device has arrived and i have now opened my Box.

I did not try to get the certificates yet, but i took some Pictures, because someone was looking to update the documentation with non modified pictures.

Iam not sure where i have read this, but i post them here in hopes that the person who was looking for this finds this post.


I could also take some more if its needed.

Thank you for sharing. Those pictures are great for that purpose

Just to make sure i have the correct Hardware. This Device should work, right? Because the Browser did not find any compatible devices. Chrome and Edge had the same problem.

Hailege 2pcs CP2102 USB 2.0 to TTL UART Serial Converter Module 5Pin STC PRGMR with Dupont Wire : Amazon.de: Computer & Zubehör

I will try again later and i will also try to make some photos for the documentation if i remember. The things I did so far (maybe I did something wrong):

The LED of the Board stayed off, so it seems to me, that the jumper part worked. Is there somethin else obviously wrong?

I did some fiddling around but had no luck.
I did try to change RxD and TxD, i tried getting it to show up in VSCodes Serial Monitor, but it doesnt even show up in the Ports listing.

Did I do something wrong or did i maybe buy the wrong USB Adapter?




If the USB-UART doesn’t show up it is either a driver problem (unlikely, as they most run out of the box) or the device is defective.
You may try to connect the USB-UART first, then power your box or vice versa.
You may also try arduino to check it with the serial monoitor

1 Like

It really was a drive issue. Windows 11 does not seem to work out of the box with this chip.

The Universal Driver from this page did help: CP210x USB to UART Bridge VCP Drivers - Silicon Labs (silabs.com)

It didnt work first try. But after turning it off and on again multiple times it started reading the flash

i currently try the same, which baud-rate did you use to see a readable promt at the serial monitor?

I did not get a readable Output there. For me it was enough, that the Port showed up and i could then try it in the Browser.
But i did need multiple attempts to write back the modified bin.

I just get IT working If i use Python Tool instead of the Website and bridge the j100 only short in boot.

after some new tests - it worked at the website if i use google chrome.
But flashing back (als mentioned at the beginners guide here) was only possible by the phython-tool.

A post was split to a new topic: Cert extraction fails