Bricked my box?

hi guys!

I did my first steps with cc3200tool, PCB Clip and UART Adapter.
But - i got no connection - anyway …

After disconnecting the clamp and reconnect the battery to the board the box won’t beep anymore.

Is it that easy to brick the box (perhaps the PCB Clip slipped …) or have I overlooked something else?


What do you mean by no beep?
Does the box wake up and pulses green? Or does the box just glows green when on power?

What you did, what was your wiring?

– box just glows green when on power
– wiring:
Debug 1 to UART RX
Debug 2 to UART TX
Debug 3 to Debug 9
Debug 4 to UART DTX
Debug 5 to UART Ground

wrong UART voltage? 5V … :see_no_evil: :see_no_evil: :see_no_evil:

Too bad. This could lead to several damages.

You may rescue the certificate of your box from the flash (if it is still intact). The rest may need replacement of several parts.

tried again with 3,3V and wiring as discribed

cc3200tool -p /dev/ttyUSB0 --sop2 ~dtr --reset rts list_filesystem
2024-01-25 22:25:54,107 – Connecting to target…
2024-01-25 22:25:56,507 – timed out while waiting for ack

any other options to get some informations from the box with my equipment?

thank you for support!!!

Does the box boot without SOP2 bridged to VCC? What does happen?

with bridged SOP2 and without - box just glows green when on power

This mean the box doesn’t boot and is in a passive state. This could mean something is broken.

You may try to backup the flash with a SOP8 clamp.

Rescuing the box itself will be more tedious, as you need to identify the defective parts.

partly good news - i solder an old floppy connector to the debug ports and now i’m able to establish a connection

but i’m not able to extract files from the flash.
full dump will work with read_flash

but there es also no output with list_filesystem
i assume - my cc3200 has a defect?

cc3200tool -p /dev/ttyUSB0 --sop2 ~dtr list_filesystem
2024-01-26 20:16:30,063 – Connecting to target…
2024-01-26 20:16:32,359 – timed out while waiting for ack
2024-01-26 20:16:32,629 – Connected, reading version…
2024-01-26 20:16:32,643 – connected to target
2024-01-26 20:16:32,644 – Version: CC3x00VersionInfo((0, 4, 1, 2), (0, 0, 0, 0), (0, 0, 0, 0), (0, 0, 0, 0), (16, 0, 0, 0))
2024-01-26 20:16:32,644 – This is a CC3200 device
2024-01-26 20:16:32,644 – Switching to NWP bootloader…
2024-01-26 20:16:32,660 – Switching UART to APPS…
2024-01-26 20:16:32,675 – Resetting communications …
2024-01-26 20:16:33,953 – Uploading rbtl3100s.dll…
2024-01-26 20:16:33,953 – Getting storage list…
2024-01-26 20:16:34,672 – APPS version: CC3x00VersionInfo((0, 4, 0, 2), (0, 0, 0, 0), (0, 0, 0, 0), (0, 0, 0, 0), (16, 0, 0, 0))
2024-01-26 20:16:34,672 – Getting storage info…
2024-01-26 20:16:34,688 – storage #2 info bytes: 0x10, 0x0, 0x4, 0x0, 0x0, 0x0, 0x0, 0x0
2024-01-26 20:16:34,688 – Getting storage list…
2024-01-26 20:16:34,704 – Reading raw storage #2 start 0x0, size 0x2000…

2024-01-26 20:16:34,831 – [0] detected a valid FAT revision: 132
2024-01-26 20:16:34,831 – [1] detected a valid FAT revision: 131
2024-01-26 20:16:34,831 – Getting storage list…
2024-01-26 20:16:34,847 – Reading raw storage #2 start 0x1774, size 0x2774…

2024-01-26 20:16:35,011 – selected FAT revision: 132 (active)
2024-01-26 20:16:35,011 – Serial Flash block size: 4096 bytes
2024-01-26 20:16:35,011 – Serial Flash capacity: 1024 blocks
2024-01-26 20:16:35,012 –
2024-01-26 20:16:35,012 – file start size fail flags total filename
2024-01-26 20:16:35,012 – index block [BLKs] safe [BLKs]
2024-01-26 20:16:35,012 – ----------------------------------------------------------------------------
2024-01-26 20:16:35,012 – N/A 0 5 N/A N/A 5 FATFS
2024-01-26 20:16:35,012 –
2024-01-26 20:16:35,012 – Flash usage
2024-01-26 20:16:35,012 – -------------------------
2024-01-26 20:16:35,012 – used space: 5 blocks
2024-01-26 20:16:35,012 – free space: 1019 blocks
2024-01-26 20:16:35,013 – memory hole: [5-1023]
2024-01-26 20:16:35,013 – All commands done, bye.

feel free to send me the full dump via telegram.
Please check if multiple dumps are identical

The cc3200 seems to be ok, as it handles the connection to the cc3200tool.
It seems that the filesystem is not okay.
You may try to read the list_filesystem with the --inactive flag, this may lead to a list of files.

This post may also be helpful. We may extract the certificates from the dump and rebuild the flash by hand.
No bootable images found / FsOpen - Error [Help needed for unbricking] - #11 by ZuttiKe

I have implemented reading the inactive filesystem slot in the cc3200tool v1.2.2. Beware, this may produce garbish, as the active filesystem may already write onto it.

Dump all files

cc3200tool -if youdump.bin list_filesystem --inactive
cc3200tool -if youdump.bin read_all_files mydump/ --inactive

This way you can dump all the files of the flash into a readable form. This may also dump internal files of the cc3200, like the servicepack.
Those technical files are dump with 0 length or missing completely if done via UART.

As an alternative, you may try dumping them with binwalk

binwalk --dd='.*' youdump.bin

Test the certificates

Please be sure, that your certificates are OK. The ca.der is the same on all boxes, the client.der and private.der are individual for each box.
copy the files to the certs/client/ directory of teddyCloud, enable the Cloud + the time API in the configuration on the webinterface and open “/v1/time” and check if you get a unix timestamp back + check the logs if the request was made to the cloud.

Delete special files

Please delete

cd mydump/
rm sys/servicepack.ucf # cannot be flashed this way
rm sys/ # the box will boot, but without the jingle and blink red.
cd ..

Rebuild flash

Please download the service pack from TI to download the servicepack.

cc3200tool format_flash -s 4M
cc3200tool write_file --signature ota_1.0.1.13- ota_1.0.1.13- /sys/servicepack.ucf # Download from TI
cc3200tool write_all_files mydump/

You may now try to boot your box again.

file extraction with v.1.2.2 was successful
also the rest of the process worked as described

my Box is working again! Thank you very much!!!

now next project - teddycloud :grinning: